Mount NTFS read/write in macOS Sierra 10.12

So, you need to use a NTFS formated storage device in macOS Sierra, but your Mac mounts it as "read only".

Since long time you can use several options (free or paid software)

But macOS Sierra kernel can mount NTFS in read/write mode, is just that it defaults to "read only" and there is not an easy way to change this.

You can edit your /etc/fstab file, but you must do that for every device you want to use.

You should use UUID in fstab. You can get the UUID excuting:

diskutil info `df "/Volumes/My disk" |\
awk '/dev/ {print $1}'` |\
awk '/Volume UUID:/ {print $NF}'

where you should replace "My disk" with the actual name of your disk.


But there is another way: hack your "mount_nfs" command

DISCLAIMER: Use this hack at your own risk. If you lose all your files or your mac burst into flames, is not my fault :-)

DISCLAIMER: macOS Sierra NTFS driver is experimental. In fact, it could trash your NTFS filesystem. YMMV.


  1. Disable csrutil
  2. Open Terminal and execute this as root (use "sudo bash")
    cd /sbin
    mv mount_ntfs mount_ntfs.orig
    cat > mount_ntfs << EOF
    #!/bin/sh
    
    IFS=
    LD_LIBRARY_PATH=
    PATH=/usr/bin:/bin:/usr/sbin:/sbin
    
    exec /System/Library/Filesystems/ntfs.fs/Contents/Resources/mount_ntfs \
    -o rw \
    -o nobrowse \
    ${1+"$@"}
    EOF
    chmod 755 mount_ntfs
    
  3. Enable csrutil

Notes:


Last Modified: December 23, 2016